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Kroll Version 10 Service Pack 34 Feature Release Notes 
This document is a compilation of new Features in Kroll Version 10 Service Pack 34. The purpose is to keep 

users informed of changes to the software and to help users implement and adapt to those changes. 

Important!  
Please carefully read the details of KRL-15905 Warning Notification on page 9 and take special note of the 

subsequent hard stop in the next service pack, SP35. 

 

Accounts Receivable 
[KRL-17033] Invoice search field no longer available while applying payments to invoices in AR 
Module 

Feature 
In an earlier release, the Search field was available when applying payments to invoices. At some point, this field 

was removed.  

The Search field is again available when applying payments to invoices.  

When you manually enter an invoice number, the system looks for that invoice number within the list of available 

invoices for payment, instead of all invoices in the system. When you click Next, that invoice number has focus, 

and the payment is applied to that invoice.  

If an invoice number is given and payment amount is greater than invoice amount then it will ask “Do you want to 

pay multiple invoices?” 

• If Yes, then it show next tab with preselected invoices (Invoice matching invoice number and oldest invoice(s) 

for remaining amount). Make a selection and click Finish to assign the payment to the selected invoices. 

• If No, and account is “Post pay account” then the payment is assigned to the designated invoice number and 

remaining payment is unassigned. 

If you manually specify an invoice number that is not part of the eligible list, this is indicated via a message. When 

you clear this message you are returned to the Invoice field. 

If you do not enter an invoice number and click Next, a list of eligible invoices appears. The oldest eligible invoice 

or the invoice that has a matching amount has focus, and by default, the payment is applied to that invoice 

(current functionality).  
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Fill  
[KRL-18794] Add 'Lab Results' as a new document type on the scan screen. 

Feature 
NOTE: This feature was originally implemented for QC in the DSQ Conformance branch, this case serves to 

make it available in all other provinces as well. 

A new functionality has been implemented to allow pharmacists to efficiently manage laboratory results by 

scanning them using the Utilities > Printed Document Scan/Import feature and saving them in the patient's 

record. This enhancement improves documentation, ensures better record keeping, and provides easier access 

to historical lab results for patient care. 

The feature includes the following improvements: 

• Document Scan Reconciliation Screen: 

A new 'Lab Results' option has been added to the Document Type dropdown. When 'Lab Results' is selected: 

• The Patient selection field is displayed (similar to when Patient Document is selected). 

• The F3 button is available for patient selection.  

• A Title field is displayed. Data entered in the Title field is saved as the document's title in the Documents 

view in the F3-Patient Card. 

Processing a document with 'Lab Results' selected saves it as a 'Lab Results' document in the patient's 

Documents. 
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• The event (document added to patient Documents) is logged in the patient’s history (F3 - Patient > View > 

History). 

 

• In F3 - Patient > View > Documents, lab results appear under their own document type. When viewing a lab 

result from Patient Documents, users have the option to print the document and edit its description. 
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This new functionality allows pharmacists to properly manage lab results by scanning and processing these 

documents, which are then saved in the Patient Documents section of the patient profile. This improvement 

enhances record keeping and provides easier access to historical lab results for patient care. 

Immunization 
[KRL-17690] Modify the Influenza component of the Immunization Module to support a single FFS 
claim model (Saskatchewan) 

Feature 
Influenza immunizations no longer support a two-claim model. For Saskatchewan, there is no longer a separate 

fee claim for Influenza immunizations, just the product billing that contains the fee. 

[KRL-18052] Allow pre-printing for consent forms when using Electronic Immunization module 

Feature 

Kroll now allows users to pre-print electronic immunization forms before completing the immunization record. 

When the system is configured for Electronic Immunization, users can select Print Now from the Immunization 
selection prompt. This option displays the Immunization Report screen.  
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The new Report Style section offers three printing options:  

• Consent form only for electronic versions 

• Consent form with product/administration for paper versions 

• Product/Administration only 

The system creates an immunization record with a new Consent Pending status, allowing the form to be 

completed manually and scanned back in later. Users can also reprint forms and update existing records using 

the Call Up functionality.  
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This feature supports all immunization types (COVID19, Influenza, and non-Influenza) and maintains compatibility 

with existing paper and RxConsult workflows. 

Network Profile 
[KRL-15320] NL | Prevent Network Profile from appearing on Professional Services when no 
Medication is prescribed 

Improvement 
In Newfoundland, there is no requirement that the Network Profile appear on FFS (Professional Service 

encounters) that does NOT result in a Prescription. The automatic profile query was being triggered when there 

were only billing service fees during a patient encounter.   

With this release, when a service fee or a professional service encounter is processed, the Network Profile no 

longer appears. However, if a prescription is processed during the same encounter, the Network Profile will still 

appear. 

Operating System 
[KRL-15905] Warning Notification for Users Running Kroll on Unsupported Windows Versions 

Feature 
When SP34 Fill is launched on PCs with operating systems older than Windows 10 or Server 2016, users will 

receive a persistent pop-up message. The only way to keep this pop-up from appearing is to update the Windows 

operating system. The notification informs users that their Windows version is unsupported and advises them to 

upgrade to Windows 11 or Server 2022 (the current recommended operating system for Kroll workstations as of 

the writing of these notes). Kroll will cease to function on unsupported operating systems as of Service Pack 35.  
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Patient Encounters (formerly Professional Services) 
[KRL-17234] Improved Patient Encounters Organization / 
[KRL-18928] Patient Encounters Module Enhancement - Recent Encounter Display 

Feature 
The Patient Encounters section has a new tile-based interface that groups encounters into eight types (e.g., 

General Counselling, Medication Review, Professional Notes, etc.). Only encounter types with existing patient 

history are displayed. 
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Each tile shows the encounter type name and total count of past entries, along with a preview of the most recent 

encounter including: 

Service Type  Displayed when applicable 

Reviewed Date  Shown in DD/MM/YYYY format 

Encounter Status  Current status information 

 

Hover over any tile to see additional details about the most recent encounter.  

 

Fee Status  Current billing/fee information 

Created Date  When the encounter was initially created (DD/MM/YYYY) 

Completed Date  When the encounter was finished (DD/MM/YYYY) 

Started by  User who initiated the encounter 

Completed by  User who finalized the encounter 

Provided by  Healthcare provider information 

Drug(s)  Associated medications when applicable 

 

Each tile includes a count of the total number of encounters of that type. This count updates as new encounters 

are added.  



Kroll V10 SP34 Feature Release Notes  13 

Click any tile to view all historical encounters of that specific type in the familiar grid layout. The grid layout has 

been updated to display a Service Type column by default (see KRL-17236 below).  

To create a new encounter directly from a tile, click the + (plus) button or press Ins when the tile is highlighted. 

This method of creating an encounter offers you an option to copy from a previous encounter, to save time when 

documenting similar services. Alternatively, click + New Encounter for quick access to all encounter types. 

All existing keyboard shortcuts (N for new, P for print, etc.) continue to work, as do the same sorting and filtering 

capabilities.  

[KRL-17235] Linking encounters when copied 

Feature 
The Patient Encounters (formerly Professional Services) grid has been enhanced to help track when services 

are used as templates, making auditing and validation easier.  

 

The system automatically records the date whenever you copy a service as a template. A new optional Copied 
on column (to show or hide this column, select Extra Functions > Change Columns) shows when a 

professional service was used to create another via "Copy from Last". This column displays dates in dd/mm/yyyy 
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format and stays blank for services that have not been copied. You can sort by this or any other column by 

clicking the column header (oldest to newest copy date or newest to oldest copy date).  

Benefits of the new feature include the following:  

• Better Auditing: Easily see which services are frequently used as templates and when 

• Enhanced Transparency: Quickly identify relationships between original and copied services 

• Streamlined Tracking: No manual work required - the system handles all the tracking automatically 

All your existing professional services data remains unchanged (the Copied On field will not be populated for 

existing encounters) and fully accessible. 

[KRL-17236] Display Encounter Type and Service Type as Separate Columns 

Feature 
Previously, patient encounters displayed a single Type column. The encounter and service types were not 

distinct. Users could not sort or filter by either attribute, making it difficult to interpret the purpose of an encounter. 

With this release, separate Encounter Type and Service Type columns replace the Type column. 
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You can use the column picker (Extra Functions > Change Columns) to show/hide the Encounter Type 

column in filtered views. Using the Encounter Type tile filter and sorting by the Service Type column will help you 

find specific encounters quickly.  

All pre-existing encounter data remains unchanged and fully accessible 

[KRL-17237] Rename “Professional Services” to Patient Encounters”  

Feature 
To improve clarity and better reflect real-world use, the “Professional Services” section has been renamed to 

“Patient Encounters” across all screens, reports, and menus. This update helps ensure pharmacists and staff 

can navigate and document patient interactions with greater ease and understanding. 

 

 [KRL-19029] Patient Encounters Module Enhancements 

Feature 
To make the Patient Encounters module, accessible from Patient > View > Patient Encounters, more 

consistent, the following functionality has been implemented:  
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• The All Patient Encounters button stays visible at the top-left during scrolling. 

• Encounter type buttons are now automatically sorted alphabetically for easier navigation. 

• The  Add Patient Encounter + button always appears last in the grid regardless of sorting.  

 

Hover hints have been added to each tile:  

• Add Encounter Icons: Plus sign icons now display "Add Encounter (Ins/+)" tooltip on hover 

• History Count Icons: Count icons show "Show history" tooltip for clear functionality indication 

When you click on a tile in the Patient Encounters main screen, the grid layout for that encounter type opens.  



Kroll V10 SP34 Feature Release Notes  17 

 

The header updates to show the specific encounter type that is being viewed. The All Encounters view maintains 

the "Patient Encounters" header.  

RAMQ Certification Bureau – TGV Certification 
[KRL-17714] Legal Terms Presentation, Enforcement, and Logging 

Feature 
Kroll terms of use enforcement and information has been added in various areas.  

On the User Information screen (Edit > Users and Groups, choose a user), a TELUS Health Terms of Use 
button has been added. Click to review the terms of use.  



Kroll V10 SP34 Feature Release Notes  18 

 

A "TELUS Health Kroll Terms of Use" option has been added to the Help menu. 

 

On the Kroll Configuration Parameters screen (File > Config > Kroll), new options have been added to 

enforce acceptance of TELUS Health Kroll Terms of Use: 



Kroll V10 SP34 Feature Release Notes  19 

 

A “TELUS Health Kroll Terms of Use“ prompt now appears on a user’s first view of the “TELUS Health Kroll 

Terms of Use“, or on version update, or on expiry. 
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When a user attempts to access Kroll via the touch screen pick-up interface without having accepted the Terms of 

Use, an "Access Denied" warning message will display. 
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In addition, some label captions have been changed:  

• Pharmacist ID label caption has been changed to Professional Licence 

• Pharmacist ID 2 label caption has been changed to Professional Licence 2 

[KRL-18436] Time-Based Access Restriction for User Accounts 

Feature 
In order to be compliant with TGV and DSQ privacy and security standards, system administrators can now 

restrict user access to the Kroll PMS based on a date range and a configurable time schedule for each day of the 

week.  

To access the tool, from the main menu choose Edit > Users and Groups, and then choose a user.  

On the User Information dialog box, click Enable User Access Schedule.  
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You can now click User Access Schedule to open the following dialog box: 

 

Administrators can configure:  
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• Time slots per day of the week  

• A Start and End access date range via side-by-side date fields in the Add Access Exception section of the 

screen 

The system will restrict user access to the PMS outside of these configured periods 

This feature is designed for specific, seldom-used cases to satisfy TGV/DSQ certification requirements, and is not 

intended for mass application across pharmacy staff. It serves government regulatory requirements rather than 

frequent operational use.  

Access restrictions only apply when Enable User Access Schedule is checked. If it is enabled and a user tries to 

login outside of their permitted schedule, they will see an Access Denied message.  

 

A user whose “shift has ended” while they are still logged in won’t get kicked out. They will be able to complete 

tasks, with the caveat that some tasks will not be available.  

[KRL-18917] Patient Profile Verification System for Quebec Pharmacies 

Feature 
To meet Quebec TGV compliance requirements, Patient cards now display color-coded verification status icons:  

• Green: Current (verification up to date) 

• Yellow: Approaching due date (within 30 days) 

• Red: Overdue verification 
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If you hover the mouse over the verification icon you can see see the Last verified date and Next verification 
due dates.  

 

Click the verification icon to update the patient’s verification date.  
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Verification dates are flexible, but default to 1 year from verification. Users can proceed without verification if 

needed while maintaining visual alerts.  

Audit Trail: All verification actions are logged in the audit trail for compliance tracking.  

This feature is automatically enabled for Quebec pharmacies and can be configured for other regions as needed. 

Reports 
[KRL-18311] Track and record User Initials at Drop Off and Data Entry for the Electronic Hardcopy 
Report 

Feature 

The Electronic Hardcopy Report prints a section at the bottom of the page that indicates who completed a 

workflow step for a prescription filled at the store. Two important workflow steps were not being included: 

• Drop Off 

• Data Entry 

The report has been modified to include the above two workflow steps, including: 
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• The workflow action  

• Initials of who did it (if completed by a user associated with a pharmacist, the initial of the user that 

completed the action will show in the By column, but the pharmacist to whom they are associated and their 

license is noted under the Signature column) 

• When (Date and Time) 
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Search 
[KRL-14380] Create missing indexes that could cause slowness for stores with large amounts of 
records 

Improvement 
Some indexes were missing in queries joining to another table or column in Where and Order by clauses. This 

caused long durations and high reads when profiling. These indexes have placed into each supplemental SQL 

script. 

Translation 
[KRL-14981] Drug Search 

Feature 
The French translations in this section have been corrected.  

[KRL-15451] French Translation for Kroll PMS UI – Reports 

Feature 
The following reports are now available in French: 

• Active Drug Listing Report 

• Adjudication Totals 

[KRL-16161] Store-level Configuration - Adjudication Tab – General Tab 

Feature 
This section has been fully translated.  

 [KRL-16901] Store-level Configuration - Interfaces Tab - Outbound Communications 

Feature 
This section has been fully translated.  

 [KRL-17890] Store-level Configuration - Rx-Tab - Prompting Tab 

Feature 
The French translations in this section have been corrected.  
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Vigilance 
[KRL-17854] Display Allergies and Conditions in the language your session is running in  

Feature 
In previous releases, Kroll did not show translated fields for allergies and conditions when the session was loaded 

in a language different from the database using Vigilance.  

With this release, for databases using Vigilance, users can enter and see allergies and conditions in the language 

the session is run in.  

[KRL-17497] Support Vigilance's stand-alone Profile Analysis utility from the patient screen 

Feature 
Vigilance has an open-ended Web-based analysis page that allows users to manually enter in details to perform 

drug interaction checking. They also support the ability to receive details from the store to pre-populate their tool 

and then allow the user to change details to see how the analysis changes. These changes are not affected in the 

patient record, they are just a tool for simulation. 

Stores that use Kroll do have the ability to access this tool through the Utilities menu. However, when the user 

selects this option, no patient details are included because there is no patient selected. Therefore, the tool always 

appears to the user in an empty state, forcing them to manually enter everything in. 

A new option has been added to the Patient screen to allow a user to rerun the analysis with the stand-alone 

utility. This way, the web screen appears already pre-populated with patient details. 

The existing “Profile Editor” option accessed from the Utilities → Vigilance Utilities menu has been re-labelled 

“Profile Analysis”. Selecting this option from the Utilities menu will continue to behave as it does today. No patient 

information will be included and must be inputted manually when the web utility appears. 
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